• 首页 首页 icon
  • 工具库 工具库 icon
    • IP查询 IP查询 icon
  • 内容库 内容库 icon
    • 快讯库 快讯库 icon
    • 精品库 精品库 icon
    • 问答库 问答库 icon
  • 更多 更多 icon
    • 服务条款 服务条款 icon

vue3解决[vite] Internal server error: Preprocessor dependency “sass“ not found. Did you install it?

武飞扬头像
狮子座的男孩
帮助1

1、问题描述:

其一、报错为:

Preprocessor dependency "sass" not found. Did you install it?
[vite] Internal server error: Preprocessor dependency "sass" not found. Did you install it?

中文为:

未找到预处理器依赖项“sass”。 你安装了吗?
[vite] 内部服务器错误:未找到预处理器依赖项“sass”。 你安装了吗?

其二、报错面显示为:

学新通

2、问题分析:

根据报错的代码提示,原因为:没有安装 sass 依赖,安装应该就能解决问题

3、问题解决:

其一、安装 sass 依赖命令:

npm install --save-dev sass

学新通

其二、重启项目(即:项目命令,一般命令如下):

npm run serve

学新通
此时的问题,一般就能解决;

其三、如果还是报错:

可以考虑用命令 npm i 重装一下 node_modules ,然后再执行项目 npm run serve

此时的问题,一般就能解决;

4、小结:

其一、哪里有不对或不合适的地方,还请大佬们多多指点和交流!
其二、有兴趣的话,可以多多关注这个专栏(Vue(Vue2 Vue3)面试必备专栏):https://blog.csdn.net/weixin_43405300/category_11525646.html?spm=1001.2014.3001.5482

本篇文章来至:学新通

  • 版权申明: 本站部分内容来自互联网,仅供学习及演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,请提供相关证据及您的身份证明,我们将在收到邮件后48小时内删除。
  • 本站站名: 学新通
  • 本文地址: https://www.swvq.com/boutique/detail/tanhcjbahi
  • 联系方式: luke.wu#vfv.cc
系列文章
更多 icon
同类精品
更多 icon
我要评论
我的头像
精彩评论
继续加载